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iFileName User and Installation Manual 

 
Thank you for using iFileName for Inventor. This software has been designed to 

provide a simple, easy to use interface to offer automatic file naming during the day to 

day use of Autodesk Inventor. We have tried to make it as unobtrusive as possible. 

 

 

 

Addin Features. 
 

• Configurable interface – iFileName can interface with either a MS Access 

database or Autodesk Productstream, for allocation of filenames. 

• Unlimited numbering sequences and be configured. We provide the same 

flexibility of number scheme generation from our MS Access database that is 

available within Autodesk Productstream. 

• Productstream users will benefit from item number reservation during part and 

assembly creation. 

• Seamless integration with Autodesk Inventor’s standard commands. Whenever 

a call for the creation of a new file is made you are offered a choice of 

numbering schemas to define the filename. 
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Chapter 1 
 

1.1. Installation. 
 

The installation must be completed on each machine that used Autodesk Inventor. 

Once installed, a new add-in will be available from within Autodesk Inventor, see the 

Usage and Configuration section of this manual for instructions. 

 

The desired configuration must be completed on each machine and is done once per 

machine even if multiple users share the same machine. 

 

The installer must have local Administrator privilege to install this product. 

 

If you have any difficulty during the installation and configuration of this software the 

please refer to the Troubleshooting section at the end of the manual. 
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1.2. Configuration. 
 

The setup of iFileName is available only when you do not have any Inventor 

documents open. It is accessed from the Tools pulldown menu of Inventor. Selecting 

the ‘iFileName Setup’ option will display the dialog as shown below.  

 

 

 
Setup Dialog Database Link selected. 

 

1. Shows the current authorization status of this addin. 

2. The whole of this add-in can be enabled/disabled by toggling this checkbox. 

3. Choose the database type to use. The Productstream Link option will only be 

available if your current project is a Vault project. The setup dialog will 

change to reflect this change, see below for details. 

4. The path to the MS Access database. This will default to the installation 

directory. The database file ‘iFileName.mdb’ can be copied to a network 

location and shared by all Autodesk Inventor users. 

 

 

Do not try to use the Productstream option if you do not have Productstream installed 

even if you are a Vault user, it will not work. 

2. Enable/ 
Disable the 
Addin 

3.  

Interface 
Type. 

4. 
Database 

Path 

1. 

Current 
Status 
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Setup Dialog Productstream Link selected. 

 

The dialog shown above shows the Productstream Link setup dialog. As stated within 

this dialog the information entered here is only used if you do not have 

‘Automatically login next session’ enabled as shown below. The use must have 

Productstream creator rights, they must be able to create ne items within the item 

master. 

  

1. Productstream server name. 

2. Productstream database name. 

3. Productstream user name. 

4. Productstream user password. 

  

 
Vault Login Dialog 

 

1.  
Vault 

Server 

2.  
Vault Name 

3.  
Vault User 

4.  
User 
Password 

Automatic 
login 
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If you do have a Vault project you can still use the MS Access database link. 

 

Selection of the OK button will validate the setup details entered. 
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1.3. Use of Addin using inbuilt Database. 
 

Using the database option requires you to define the numbering schemas that you 

require. This is done using the ‘iFileName Database Editor’ application which was 

installed as part of this software. Refer to chapter 2 of this manual for details of how 

to setup your numbering schemas. 

 

Once you have the numbering schemas defined and the addin enabled you are ready 

to go. 

 

The addin will interrupt all calls to create a new Inventor file. This is usually in 2 

main areas 

 

3.1 New file creation using the File>New menu options 

3.2 In-place component creation from within an assembly. 

 

 

3.1. File>New 

 

After selection of the template file, as usual, an additional dialog box will be 

displayed as below: 

 

 
Addin dialog. 

 

From the dropdown list you can select any active numbering schema that you have 

defined. 

 

The definition of the numbering schema will be displayed. The options available will 

depend upon the definition of the numbering schema. Refer to the ‘Numbering 

Schema Field Types’ section of this manual for details. 

 

Once you have selected the numbering schema to use selection of the ‘Ok’ button will 

continue the ‘New’ command as usual with one exception, the file name of the new 

document will be defined automatically based upon the numbering schema selected. 

Checks will be made to ensure that the filename has not been used previously within 

the database.  

 

If the ‘Cancel’ button is selected the standard Inventor command will continue, ie you 

will have files named ‘Part1’/’Assembly1’ etc. 



 8 

b. In-place component creation. 
 

With in-place component creation the following dialog is displayed prior to the 

standard Inventor dialog box. 

 

 

 
In-place Component Creation. 

 

The in-place dialog is almost the same as the File>New dialog. The only difference is 

that you must also select the ‘File Type’ from the dropdown menu. 

 

From the dropdown list you can select any active numbering schema that you have 

defined. 

 

The definition of the numbering schema will be displayed. The options available will 

depend upon the definition of the numbering schema. Refer to the ‘Numbering 

Schema Field Types’ section of this manual for details. 

 

Once you have selected the numbering schema to use selection of the ‘Ok’ button will 

continue the ‘New’ command as usual with one exception, the file name of the new 

document will be defined automatically based upon the numbering schema and file 

type selected. Checks will be made to ensure that the filename has not been used 

previously within the database.  

 

If the ‘Cancel’ button is selected the standard Inventor command will continue, ie you 

will have files named ‘Part1’/’Assembly1’ etc. 

 

 

And That’s it! 
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1.4. Use of Addin with Productstream. 
 

Using the Productstream option does not require any additional definition of 

numbering schemas. All of the required numbering schema will have already been 

defined by your Productstream administrator. 

 

Each time you use a numbering schema the resulting filename will be created as an 

item within the ‘Item Master’ of Productstream. The title of the new item will be set 

to ‘Inventor Reserved Item‘ to denote that is an Inventor created item number. No file 

will be attached to the item, it is just a place holder for when the Vault file is 

promoted to and item in the future. 

 

When assigning items you will have a ‘Duplicate conflict’ for each file that has been 

created using this addin. 

 

 
Assign Item Find Duplicates. 

 

Simply select the ‘Auto-select first duplicate as shown above. The duplicate is the 

reserved item that was created when the file was created. 

 

The title property of items must be mapped to the title property of the file to ensure 

that the item title will update from the file. 

 

Duplicates 

Auto-Select 
first 

duplicate 
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Item Property Manager 

 

 

The addin will interrupt all calls to create a new Inventor file. This is usually in 2 

main areas 

 

4.1 New file creation using the File>New menu options 

4.2 In-place component creation from within an assembly. 

 

 

4.1. File>New 

 

After selection of the template file, as usual, an additional dialog box will be 

displayed as below: 

 

 
Addin dialog. 

 

From the dropdown list you can select any active numbering schema that you have 

defined. 

 

The definition of the numbering schema will be displayed. The options available will 

depend upon the definition of the numbering schema.  

Ensure 
Data source 
is File 
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The item type for Productstream must also be selected. 

 

Once you have selected the numbering schema to use selection of the ‘Ok’ button will 

continue the ‘New’ command as usual with one exception, the file name of the new 

document will be defined automatically based upon the numbering schema selected. 

Checks will be made to ensure that the filename has not been used previously within 

Productstream.  

 

If the ‘Cancel’ button is selected the standard Inventor command will continue, ie you 

will have files named ‘Part1’/’Assembly1’ etc. 

 

4.2. In-place component creation. 
 

With in-place component creation the following dialog is displayed prior to the 

standard Inventor dialog box. 

 

 

 
In-place Component Creation. 

 

The in-place dialog is almost the same as the File>New dialog. The only difference is 

that you must also select the ‘File Type’ from the dropdown menu. From the 

dropdown list you can select any active numbering schema that you have defined. 

 

The definition of the numbering schema will be displayed. The options available will 

depend upon the definition of the numbering schema. The item type for Productstream 

must also be selected. 

 

Once you have selected the numbering schema to use selection of the ‘Ok’ button will 

continue the ‘New’ command as usual with one exception, the file name of the new 

document will be defined automatically based upon the numbering schema and file 

type selected. Checks will be made to ensure that the filename has not been used 

previously within Productstream.  

 

If the ‘Cancel’ button is selected the standard Inventor command will continue, ie you 

will have files named ‘Part1’/’Assembly1’ etc. 

 

And That’s it! 
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1.5. Troubleshooting installation and configuration. 
 

There should be very little that can go wrong with this addin. Below are a number of 

possible problems with the solutions to resolve the problem. 

 

1. No ‘iFileName Setup’ available from the Tools pull-down. 

 

Check that the addin is loaded, from the Tools>Add-in… menu look for iFileName 

addin and ensure it is both the checkboxes ‘Loaded/Unloaded’ and ‘Load at Startup’ 

are checked 

 

 
Add-In Manager 

 

Make the required changes and restart Inventor. 

 

2. iFileName not showing in the Add-in Manager. 

 

From the installation directory run the batch file ‘Register.bat’. 
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3. Database locked – Please Wait. 

 

If you have a locked database then run the ‘iFilename Setup’ command and select the 

‘Unlock’ button. Whenever a user uses our database it is locked for a short time to 

allow exclusive access. From time to time this lock is not removed and the unlock 

option is only available when the lock is found. 

 

 

4. I need to share the database on our network. 

 

During installation the database is placed within the installation directory. To allow 

multi-user access to a common database simple copy the database to a shared location 

on the network and direct each machine to access this database from the setup 

command. The database file to copy is called ‘iFileName.mdb’. Manual editing of this 

database is not supported. 

 

 

 

If you encounter any other problems the contact Cadspec on +44 1905 458000
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Chapter 2 

 

2.1. Database editor overview. 
 

 
Database editor dialog 

 

The database editor is a simple application to create and edit numbering schemas.  

 

Once you have selected the database all defined schemas are displayed as shown 

above. 

 

As can be see from the image above each schema can be edited deleted and new 

schemas created. There are a few rules that must be followed when editing schemas. 

 

• You cannot edit or delete a schema that is in use. 

• You cannot edit or delete a schema that is active. 

• The default schema must be active. 
 

To add a new schema, select the ‘New’ button. From the new schema dialog (below) 

you can add a number of different field types. Each field type can define a new 

element of the final numbering schema. 

 

For details of the various field types refer to section 2.2 of this manual. 

 

Remember to select the ‘Commit’ button to save the changes made to numbering 

schemas. 
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New schema field list dialog 

 

 

 
Field list dialog 
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2.2. Numbering schema field types. 
 

Auto-generated sequence 

• Enter a name for the auto-generated field. 

• Specify the length for the range. The length must be a positive number. 

• Enter the starting and ending value for the range.  

• Enter the StepSize. The StepSize value must be at least 1. 

• The auto-generated sequence is zero-padded by default. To remove zero-

padding, clear the check box. 

• An example of zero-padded numbers: 000001, 000002, 000003 

 

Delimiter 

• Enter the delimiter value. It must be a character, such as a dash (-), used to 

separate fields. 

 

Fixed text 

• Enter a name for the fixed text field. 

• The value entered in the Fixed text field is a constant and cannot be edited. 

The value cannot exceed 50 characters. 

 

Free text 

• Enter a name for the free text field. 

• Enter the maximum length of the field.  

• Select the Max length required check box to fix the length of the field to the 

value specified in the Max length field. 

 

Predefined list 

• Enter a name for the free predefined list field.  

• Enter a value in the Code field. You can optionally enter a description for each 

of the values. 

• To change the order of the entries, highlight a value, and then click Move up 

or Move down. 

• To delete an entry, highlight a value, and then click Delete. 
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Chapter 3  
 

Stanford Marsh group, formed over 30 years ago, are the UK's leading provider of 

design technology supplying a full range of both CAD products and Traditional 

design equipment. 

 

Offering a unique blend of knowledge for modern and traditional draughting methods 

we are able to offer a one stop solution for all your design needs combined with 

effective consultancy methods to ensure your design process is maximising your 

potential and returns. 

 

Cadspec was formed in 1989, as part of the Stanford Marsh Group, to provide the 

latest computer-aided solutions to the mechanical and architectural design industries. 

 

We are now recognised as one of the leading suppliers of CAD solutions in the UK. 

Our aim is to maximise the productivity and return on investment for our business 

partners. We recognise that to achieve this means building partnerships with our 

customers, working together to maintain a partnership which will benefit us both.  

 

Long term relationships have been the key to our success. Cadspec invests heavily in 

our staff to ensure that we have the best trained, most knowledgeable, highly 

motivated and happy team of sales and technical consultants in the industry.  

 

Above all, you can believe in the quality of our service both pre and post sales. 

Cadspec offers and delivering the highest standards at all times. 
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